Samsara degraded service event

Incident Report for HAAS Alert

Resolved

This incident has been confirmed resolved.
Posted Apr 29, 2026 - 14:42 CDT

Monitoring

Samsara has implemented a fix. We will continue to monitor the results until we see our services are fully operational.
Posted Apr 29, 2026 - 13:00 CDT

Investigating

Samsara has reported degraded API status. This issue impacting HAAS Alert customers utilizing Samsara for connectivity to our platform. We are monitoring the Samsara incident and will report here when the issue has been resolved. For current status of the issue, please visit https://www.samsarastatus.com/
Posted Apr 29, 2026 - 11:20 CDT
This incident affected: Safety Cloud® Dashboard.