Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 25, 2024 - 22:00 CDT
Scheduled
Samara has a planned database update occurring at this time. The approximate impact is expected to be 2-5 minutes within this window. If your account is impacted, you can expect to not see vehicle updates during the impacted time.
Posted Mar 22, 2024 - 17:48 CDT
This scheduled maintenance affected: HAAS Alert Safety Cloud FleetFusion and Safety Cloud® Dashboard.